Boatmad.com


Reply
 
Thread Tools Display Modes
 
Old 27-07-2014, 05:26 PM   #1
Registered User
 
blackbeard's Avatar
 
Country: isle of wight
Location: on a rock
Interests: boats,boats and boats
Boat make: Cougar 21
Engines: Merc 2.5 promax 150
Cruising area: solent

Join Date: Oct 2007
Location: on a rock
Posts: 710
200 black max no power

Hi all, my mates got an old 90s 200 black max. In neutral she revs up ok but sounds bit sluggish. When put into gear its got no power at all..
Carbs are clean just put on new rectifier as taco wasnt working
Any ideas,
Many thanks
Chris
__________________

blackbeard is offline   Reply With Quote
Old 27-07-2014, 10:38 PM   #2
Registered User
 
q-branch's Avatar
 
Country: UK
Location: Buckinghamshire
Occupation: Transmission Shop Manager Hewland Eng
Interests: Power Boats,Race Cars,Shooting
Boat name: Quantum of Solace
Boat make: Phantom 21
Engines: Mercury 150 Pro Max EFI
Cruising area: Thames & South Coast

Join Date: Sep 2013
Location: Buckinghamshire
Posts: 21
If you squeeze the primer bulb does it stay squashed ? if so you have a blocked fuel filter we had this problem last weekend
__________________

q-branch is offline   Reply With Quote
Old 28-07-2014, 07:15 AM   #3
Registered User
 
blackbeard's Avatar
 
Country: isle of wight
Location: on a rock
Interests: boats,boats and boats
Boat make: Cougar 21
Engines: Merc 2.5 promax 150
Cruising area: solent

Join Date: Oct 2007
Location: on a rock
Posts: 710
Hi, its got brand new filters. Think we sussed it,got no spark on 2 cylinders,coils good so rekon its switch box. Will change today and hopefuly sorted
Thanks
blackbeard is offline   Reply With Quote
Old 31-07-2014, 09:57 PM   #4
Registered User
 
Occupation: marine engineer
Boat make: Phantom 20
Engines: 2.4
Cruising area: littlehampton

Join Date: May 2009
Posts: 169
Sounds like a coil to me or maybe a bad earth on the switch boxes.
andy456 is offline   Reply With Quote
Old 31-07-2014, 10:12 PM   #5
Registered User
 
blackbeard's Avatar
 
Country: isle of wight
Location: on a rock
Interests: boats,boats and boats
Boat make: Cougar 21
Engines: Merc 2.5 promax 150
Cruising area: solent

Join Date: Oct 2007
Location: on a rock
Posts: 710
Port side switch box was fked only powering one coil, new switch box and now shes all good...
Thanks
blackbeard is offline   Reply With Quote
Old 31-07-2014, 10:33 PM   #6
Registered User
 
Country: UK
Location: Surrey
Occupation: Motorsport Development inc Engine Managment
Boat make: 21ft
Engines: Various
Cruising area: Solent / Kent / Cornwall

Join Date: Oct 2011
Location: Surrey
Posts: 375
You should also set the timing now. just FYI switch boxes should be replaced in pairs. If one has gone the other probably will soon too.
__________________

beyondhelp is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Powered by vBadvanced CMPS v3.2.3

All times are GMT +1. The time now is 07:09 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×