Boatmad.com


Reply
 
Thread Tools Display Modes
 
Old 16-06-2014, 01:31 PM   #1
Registered User
 
Country: thornton
Occupation: kitchen supplier and installer
Boat name: roofless
Boat make: phantom/talon 18's/scarab 21,Larson 254 cabrio
Engines: V8
Cruising area: wyre/morcambe bay

Join Date: Apr 2008
Posts: 311
2.5 efi won't rev over 5000 rpm

2.5efi on p18 runs great up to 5000 rpm the pulls back if full throttles applied,anyone any idea what the problem might be,props a 26 pitch 3 blade
__________________

the rat is offline   Reply With Quote
Old 16-06-2014, 04:43 PM   #2
Registered User
 
Country: UK
Location: Surrey
Occupation: Motorsport Development inc Engine Managment
Boat make: 21ft
Engines: Various
Cruising area: Solent / Kent / Cornwall

Join Date: Oct 2011
Location: Surrey
Posts: 375
What do the plugs look like?
__________________

beyondhelp is offline   Reply With Quote
Old 16-06-2014, 06:29 PM   #3
Registered User
 
Country: thornton
Occupation: kitchen supplier and installer
Boat name: roofless
Boat make: phantom/talon 18's/scarab 21,Larson 254 cabrio
Engines: V8
Cruising area: wyre/morcambe bay

Join Date: Apr 2008
Posts: 311
Quote:
Originally Posted by beyondhelp View Post
What do the plugs look like?
Brand new,only run for 1hr,seems to get too much air if I give it full throttle
the rat is offline   Reply With Quote
Old 16-06-2014, 06:38 PM   #4
Registered User
 
Country: UK
Location: Surrey
Occupation: Motorsport Development inc Engine Managment
Boat make: 21ft
Engines: Various
Cruising area: Solent / Kent / Cornwall

Join Date: Oct 2011
Location: Surrey
Posts: 375
So signs of running lean?
beyondhelp is offline   Reply With Quote
Old 16-06-2014, 08:57 PM   #5
Registered User
 
Country: thornton
Occupation: kitchen supplier and installer
Boat name: roofless
Boat make: phantom/talon 18's/scarab 21,Larson 254 cabrio
Engines: V8
Cruising area: wyre/morcambe bay

Join Date: Apr 2008
Posts: 311
Quote:
Originally Posted by beyondhelp View Post
So signs of running lean?
Not checked them yet but will do at the wknd,I'm on an analogue ecu if that helps?
the rat is offline   Reply With Quote
Old 16-06-2014, 09:32 PM   #6
Registered User
 
maz928's Avatar
 
Country: England
Location: Poole
Interests: Boats/cars
Boat make: Boss 21/Argentinian HotBoat
Engines: Mercury 2.5 Offshore
Cruising area: Poole/Solent

Join Date: Jul 2007
Location: Poole
Posts: 293
I'd check the throttle positioning sensor and then the high speed coils on the stator ....
maz928 is offline   Reply With Quote
Old 16-06-2014, 10:14 PM   #7
Registered User
 
Country: thornton
Occupation: kitchen supplier and installer
Boat name: roofless
Boat make: phantom/talon 18's/scarab 21,Larson 254 cabrio
Engines: V8
Cruising area: wyre/morcambe bay

Join Date: Apr 2008
Posts: 311
Quote:
Originally Posted by maz928 View Post
I'd check the throttle positioning sensor and then the high speed coils on the stator ....
I have a spare sensor so will try that,stator should be ok as it's quite new tho I've a spare and will change that too,thanks
the rat is offline   Reply With Quote
Old 16-06-2014, 10:42 PM   #8
Registered User
 
Country: UK
Location: Surrey
Occupation: Motorsport Development inc Engine Managment
Boat make: 21ft
Engines: Various
Cruising area: Solent / Kent / Cornwall

Join Date: Oct 2011
Location: Surrey
Posts: 375
Quote:
Originally Posted by maz928 View Post
I'd check the throttle positioning sensor and then the high speed coils on the stator ....
Good idea that.
__________________

beyondhelp is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Powered by vBadvanced CMPS v3.2.3

All times are GMT +1. The time now is 01:24 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×